Конференция PHP Russia. 17 мая, Москва.
SwiftMailer 2.1.0

Команда Yii выпустила версию 2.1.0 расширения SwiftMailer, которое использует SwitMailer версий 6.x.

Высокоуровневый интерфейс расширения не изменился, поэтому весь существующий код, написаный под версию 2.0.x, верятно, будет работать и с 2.1.x. Тем не менее, несколько несовместимостей всё-таки есть:

Минимально необходимая версия PHP повышена до 7.0. По умолчанию в качестве транспорта теперь используется Swift_SendmailTransport так как Swift_MailTransport больше не поставляется с SwiftMailer. Инструкцию по миграции с 2.0.x вы можете найти в UPGRADE.

Убедитесь, что версия в вашем composer.json указана верно. Если вы хотите остаться на версиях 2.0.x и SwiftMailer 5.x, используйте ~2.0.7. Подробнее о версиях можно прочитать в документации Composer.