Как указать scope для npm-пакета через composer?

Темы, не касающиеся фреймворка, но относящиеся к программированию в целом.
Ответить
yiiquestion
Сообщения: 3
Зарегистрирован: 2019.05.02, 15:26

Как указать scope для npm-пакета через composer?

Сообщение yiiquestion » 2019.05.18, 10:55

Для установки пакетов вроде ng5-slider(https://www.npmjs.com/package/ng5-slider) через composer я добавляю в секцию "require" файла composer.json строку "npm-asset/ng5-slider": "1.1.14", нажимаю composer update и всё загружается как надо.
Что нужно указать если пакет называется, например, так @react-native-community/slider(https://www.npmjs.com/package/@react-na ... ity/slider)? В имени пакета в composer нельзя использовать символы / и @. Пробовал вариант "npm-asset/react-native-community--slide": "1.1.2" , но он не работает.

Ответить