ошибка при создании нового клона yii2-basic

Общие вопросы по использованию второй версии фреймворка. Если не знаете как что-то сделать и это про Yii 2, вам сюда.
Ответить
Alex@
Сообщения: 557
Зарегистрирован: 2014.12.16, 09:24

ошибка при создании нового клона yii2-basic

Сообщение Alex@ » 2018.07.12, 10:50

Здравствуйте, не могу понять в чем проблема при создании нового проекта на yii
вот сама ошибка

Код: Выделить всё

composer create-project --prefer-dist yiisoft/yii2-app-basic basic
Installing yiisoft/yii2-app-basic (2.0.14)
  - Installing yiisoft/yii2-app-basic (2.0.14): Loading from cache
Created project in basic
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 63 installs, 0 updates, 0 removals
  - Installing yiisoft/yii2-composer (2.0.7): Downloading (failed)
Downloading (failed)
Downloading (failed)    Failed to download yiisoft/yii2-composer from dist: The "https://api.github.com/repos/yiisoft/yii2-composer/zipball/1439e78be1218c492e6cde251ed87d3f128b9534" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed
    Now trying to download from source
  - Installing yiisoft/yii2-composer (2.0.7): Cloning 1439e78be1


  [RuntimeException]
  Failed to clone https://github.com/yiisoft/yii2-composer.git via https, ssh protocols, aborting.

  - https://github.com/yiisoft/yii2-composer.git
    Cloning into 'R:\OSPanel\domains\localhost\basic\vendor\yiisoft\yii2-composer'...
    fatal: unable to access 'https://github.com/yiisoft/yii2-composer.git/': SSL certificate problem: self sign
  ed certificate in certificate chain

  - git@github.com:yiisoft/yii2-composer.git
    Cloning into 'R:\OSPanel\domains\localhost\basic\vendor\yiisoft\yii2-composer'...
    Host key verification failed.
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.


create-project [-s|--stability STABILITY] [--prefer-source] [--prefer-dist] [--repository REPOSITORY] [--repository-url REPOSITORY-URL] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--no-progress] [--no-secure-http] [--keep-vcs] [--remove-vcs] [--no-install] [--ignore-platform-reqs] [--] [<package>] [<directory>] [<version>]

Аватара пользователя
Dominus
Сообщения: 717
Зарегистрирован: 2013.03.14, 21:27
Откуда: Россия, Иваново
Контактная информация:

Re: ошибка при создании нового клона yii2-basic

Сообщение Dominus » 2018.07.12, 12:04

Так попробуйте:

Код: Выделить всё

composer self-update
composer clear-cache
composer create-project --prefer-dist yiisoft/yii2-app-basic basic
composer update
Не спорь с дураком, иначе окружающие не правильно поймут кто из вас дурак!

Alex@
Сообщения: 557
Зарегистрирован: 2014.12.16, 09:24

Re: ошибка при создании нового клона yii2-basic

Сообщение Alex@ » 2018.07.12, 12:09

вот результат

Код: Выделить всё

Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 63 installs, 0 updates, 0 removals
  - Installing yiisoft/yii2-composer (2.0.7): Downloading (failed)
Downloading (failed)
Downloading (failed)    Failed to download yiisoft/yii2-composer from dist: The "https://api.github.com/repos/yiisoft/yii2-composer/zipball/1439e78be1218c492e6cde251ed87d3f128b9534" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed
    Now trying to download from source
  - Installing yiisoft/yii2-composer (2.0.7): Cloning 1439e78be1


  [RuntimeException]
  Failed to clone https://github.com/yiisoft/yii2-composer.git via https, ssh protocols, aborting.

  - https://github.com/yiisoft/yii2-composer.git
    Cloning into 'R:\OSPanel\domains\localhost\vendor\yiisoft\yii2-composer'...
    fatal: unable to access 'https://github.com/yiisoft/yii2-composer.git/': SSL certificate problem: self sign
  ed certificate in certificate chain

  - git@github.com:yiisoft/yii2-composer.git
    Cloning into 'R:\OSPanel\domains\localhost\vendor\yiisoft\yii2-composer'...
    Permission denied (publickey).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
при выполнении команды php composer.phar diagnose выдаёт

Код: Выделить всё

> php composer.phar diagnose
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: OK
Checking https connectivity to packagist: OK
Checking github.com oauth access: FAIL
[Composer\Downloader\TransportException] The "https://api.github.com/" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E328C AD90147D AFE50952
OK
Checking composer version: OK
Composer version: 1.6.5
PHP version: 7.1.7
PHP binary path: r:\ospanel\modules\php\PHP-7.1-x64\php.exe

Аватара пользователя
Dominus
Сообщения: 717
Зарегистрирован: 2013.03.14, 21:27
Откуда: Россия, Иваново
Контактная информация:

Re: ошибка при создании нового клона yii2-basic

Сообщение Dominus » 2018.07.12, 12:49

Тут гляньте, такая же ошибка: https://github.com/composer/composer/issues/4388
Не спорь с дураком, иначе окружающие не правильно поймут кто из вас дурак!

Alex@
Сообщения: 557
Зарегистрирован: 2014.12.16, 09:24

Re: ошибка при создании нового клона yii2-basic

Сообщение Alex@ » 2018.07.13, 13:38

Переустановил composer, на локалке так же обновил опенсервер ничего не получилось - тот же результат.
так же решил развернуть проект на удалённом сервере результат

Код: Выделить всё

 /usr/local/php/php-7.0/bin/php composer.phar update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for deesoft/yii2-adminlte ~1.0 -> satisfiable by deesoft/yii2-adminlte[1.0].
    - deesoft/yii2-adminlte 1.0 requires bower-asset/adminlte ~2.0 -> no matching package found.
  Problem 2
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.15.1 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.15 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.14.2 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.14.1 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.14 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13.3 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13.2 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13.1 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.12.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.12.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.12 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 ~2.0.6 -> satisfiable by yiisoft/yii2[2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.12.1, 2.0.12.2, 2.0.13, 2.0.13.1, 2.0.13.2, 2.0.13.3, 2.0.14, 2.0.14.1, 2.0.14.2, 2.0.15, 2.0.15.1, 2.0.6, 2.0.7, 2.0.8, 2.0.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it
первая проблема меня не беспокоит.
помогите разобраться пожалуйста....

Аватара пользователя
Dominus
Сообщения: 717
Зарегистрирован: 2013.03.14, 21:27
Откуда: Россия, Иваново
Контактная информация:

Re: ошибка при создании нового клона yii2-basic

Сообщение Dominus » 2018.07.13, 13:44

Уже не тот же, теперь проблема с пакетами.
В composer.json секция

Код: Выделить всё

"repositories": [
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ]
присутствует?
Не спорь с дураком, иначе окружающие не правильно поймут кто из вас дурак!

Alex@
Сообщения: 557
Зарегистрирован: 2014.12.16, 09:24

Re: ошибка при создании нового клона yii2-basic

Сообщение Alex@ » 2018.07.13, 16:24

Dominus писал(а):
2018.07.13, 13:44
Уже не тот же, теперь проблема с пакетами.
В composer.json секция

Код: Выделить всё

"repositories": [
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ]
присутствует?
нет.

Аватара пользователя
Dominus
Сообщения: 717
Зарегистрирован: 2013.03.14, 21:27
Откуда: Россия, Иваново
Контактная информация:

Re: ошибка при создании нового клона yii2-basic

Сообщение Dominus » 2018.07.13, 16:26

Alex@ писал(а):
2018.07.13, 16:24
Dominus писал(а):
2018.07.13, 13:44
Уже не тот же, теперь проблема с пакетами.
В composer.json секция

Код: Выделить всё

"repositories": [
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ]
присутствует?
нет.
Добавьте и пробуйте:

Код: Выделить всё

/usr/local/php/php-7.0/bin/php composer.phar self-update
/usr/local/php/php-7.0/bin/php composer.phar update
Не спорь с дураком, иначе окружающие не правильно поймут кто из вас дурак!

Ответить