yii2 версии 3 и yii2-bootstrap4 несовместимы

Предварительное обсуждение найденных ошибок перед отправкой их авторам фреймворка, а также внесение новых предложений.
Ответить
Аватара пользователя
Ferro7
Сообщения: 138
Зарегистрирован: 2015.04.13, 14:17

yii2 версии 3 и yii2-bootstrap4 несовместимы

Сообщение Ferro7 » 2018.07.07, 21:09

https://github.com/yiisoft/yii2-bootstr ... nAsset.php

Код: Выделить всё

public $depends = [
     'yii\web\JqueryAsset',
Однако, https://github.com/yiisoft/yii2/blob/3. ... UPGRADE.md
('yii\web\JqueryAsset' был перемещён в 'yii\jquery\JqueryAsset')

Из-за этого ошибка "Class yii\web\JqueryAsset not found..."
Спишь?

Аватара пользователя
ElisDN
Сообщения: 4992
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Сообщение ElisDN » 2018.07.08, 00:04

Да, так как это Yii3 и Yii2-bootstrap.

Аватара пользователя
Ferro7
Сообщения: 138
Зарегистрирован: 2015.04.13, 14:17

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Сообщение Ferro7 » 2018.07.08, 10:54

https://github.com/yiisoft/yii2-bootstr ... r.json#L39

Код: Выделить всё

"require": {
        "yiisoft/yii2": "~2.0|~2.1@dev|~3.0@dev",
yii2-bootstrap4 в требованиях допускает yii 3.
И что-то я малость запутался в версиях.
Где yii 2.1? Я его не вижу на гитхабе. Выглядит, как будто yii2.1 === yii3.0
Спишь?

skynin
Сообщения: 123
Зарегистрирован: 2017.12.12, 10:09

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Сообщение skynin » 2018.07.08, 11:32

Ferro7 писал(а):
2018.07.08, 10:54
Где yii 2.1? Я его не вижу на гитхабе. Выглядит, как будто yii2.1 === yii3.0
Yii development notes #23
Jun 30
There will be no Yii 2.1
Yii officially adopts SemVer since next major version that would be called 3.0. Stable 2.0 versions are staying as is in they numbering schema.
https://www.patreon.com/posts/yii-development-19759260

Аватара пользователя
Ferro7
Сообщения: 138
Зарегистрирован: 2015.04.13, 14:17

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Сообщение Ferro7 » 2018.07.09, 15:13

Насчёт вопроса: бутрсап4 есть второй версии - его и надо использовать.
Решено.
Спишь?

Ответить