Проблема при установке фреймворка

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
izzet
Сообщения: 16
Зарегистрирован: 2016.05.16, 10:21

Проблема при установке фреймворка

Сообщение izzet » 2016.08.23, 15:29

Здравствуйте, при установке фреймворка выходит ошибка:

Код: Выделить всё

C:\xampp\htdocs>composer create-project yiisoft/yii2-app-basic basic
Installing yiisoft/yii2-app-basic (2.0.9)
  - Installing yiisoft/yii2-app-basic (2.0.9)
    Downloading: 100%

Created project in basic
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 >=2.0.5 -> satisfiable by yiisoft/yii2[2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
 
fxp/asset-plugin установил по инструкции.
composer diag вроде тоже никаких ошибок не показывает.

Подскажите пожалуйста в чем проблема? Не первый раз устанавливаю фреймворк, до этого таких проблем со стабильностью не возникало. Что-то вообще даже не верится, что это в стабильности проблема.

Спасибо заранее всем отозвавшимся.

zelenin
Сообщения: 10596
Зарегистрирован: 2013.04.20, 11:30

Re: Проблема при установке фреймворка

Сообщение zelenin » 2016.08.23, 15:31

>> fxp/asset-plugin установил по инструкции.

сомневаюсь. покажите лог консоли, в котором присутствуют две команды подряд - установка плагина и установка yii2

izzet
Сообщения: 16
Зарегистрирован: 2016.05.16, 10:21

Re: Проблема при установке фреймворка

Сообщение izzet » 2016.08.23, 15:37

Код: Выделить всё

C:\xampp\htdocs>composer global require "fxp/composer-asset-plugin:*"
Changed current directory to C:/Users/izzat.f/AppData/Roaming/Composer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Removing fxp/composer-asset-plugin (v1.1.4)
  - Installing fxp/composer-asset-plugin (v1.2.1)
    Downloading: 100%

Writing lock file
Generating autoload files

C:\xampp\htdocs>composer create-project yiisoft/yii2-app-basic basic
Installing yiisoft/yii2-app-basic (2.0.9)
  - Installing yiisoft/yii2-app-basic (2.0.9)
    Loading from cache

Created project in basic
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 >=2.0.5 -> satisfiable by yiisoft/yii2[2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
 

zelenin
Сообщения: 10596
Зарегистрирован: 2013.04.20, 11:30

Re: Проблема при установке фреймворка

Сообщение zelenin » 2016.08.23, 15:45

у меня ок отрабатывают эти команды. композер последней версии?

izzet
Сообщения: 16
Зарегистрирован: 2016.05.16, 10:21

Re: Проблема при установке фреймворка

Сообщение izzet » 2016.08.23, 15:54

Код: Выделить всё

C:\xampp\htdocs>composer diag
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: Warning: Accessing packagist.org over h
ttp which is an insecure protocol.
OK
Checking https connectivity to packagist: OK
Checking HTTP proxy: OK
Checking HTTP proxy support for request_fulluri: OK
Checking HTTPS proxy support for request_fulluri: OK
Checking github.com rate limit: OK
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB
723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E32
8C AD90147D AFE50952
OK
Checking composer version: OK

C:\xampp\htdocs>composer self-update
You are already using composer version 1.2.0 (stable channel).
 

jakiro
Сообщения: 553
Зарегистрирован: 2013.03.05, 15:15

Re: Проблема при установке фреймворка

Сообщение jakiro » 2016.08.23, 16:00

У меня подобная ошибка была при попытке установить пакет какой-то. Исправлял версию пакета, вместо конкретной, я ставил "*" или "dev", что то вроде того :)

Аватара пользователя
SiZE
Сообщения: 2698
Зарегистрирован: 2011.09.21, 12:39
Откуда: Perm
Контактная информация:

Re: Проблема при установке фреймворка

Сообщение SiZE » 2016.08.23, 16:06

Только что побороли ну и fxp глобально должен быть поставлен

SiZE, [23.08.16 17:55]
"yiisoft/yii2": "2.0.9" сделай

SiZE, [23.08.16 17:56]
или
"yiisoft/yii2": "^2.0"
в поиске работы

izzet
Сообщения: 16
Зарегистрирован: 2016.05.16, 10:21

Re: Проблема при установке фреймворка

Сообщение izzet » 2016.08.23, 16:19

Без каких-либо изменений. FXP вроде глобально ставил. Мне всё больше кажется, что эта проблема не в композере вообще. Все эти команды рабочие, это проверено.

Аватара пользователя
SiZE
Сообщения: 2698
Зарегистрирован: 2011.09.21, 12:39
Откуда: Perm
Контактная информация:

Re: Проблема при установке фреймворка

Сообщение SiZE » 2016.08.23, 16:38

izzet писал(а):что эта проблема не в композере вообще
ты замени >=2.0.5 на ^2.0 а потом поговорим
в поиске работы

izzet
Сообщения: 16
Зарегистрирован: 2016.05.16, 10:21

Re: Проблема при установке фреймворка

Сообщение izzet » 2016.08.23, 17:19

Не помогло, со stability:dev работает, только это всё равно не выход, как мне кажется. Дома никаких приключений не происходит, на рабочем компе возникает эта проблема со стабильностью

Аватара пользователя
girmate
Сообщения: 1533
Зарегистрирован: 2015.10.27, 12:52

Re: Проблема при установке фреймворка

Сообщение girmate » 2016.08.25, 00:51

Тема должна находится здесь: viewforum.php?f=17: раздел "Установка и настройка".
Осторожно! Вы общаетесь с новичком ;)

Аватара пользователя
Driver86
Сообщения: 141
Зарегистрирован: 2015.04.13, 14:17

Re: Проблема при установке фреймворка

Сообщение Driver86 » 2016.08.25, 01:53

У меня то же самое. При чём до этого всё работало. А тут решил сделать composer update и бац - ошибка.

А так же это:

Код: Выделить всё

root@kvmde21-9279:/var/www/_# composer diag
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Checking composer.json: FAIL
No license specified, it is recommended to do so. For closed-source software you may use "proprietary" as license.
require.yiisoft/yii2 : unbound version constraints (>=2.0.9) should be avoided
require.bower-asset/jquery : unbound version constraints (>=3.0.0) should be avoided
require.yiisoft/yii2-bootstrap : unbound version constraints (>=2.1.0@dev) should be avoided
require.bower-asset/bootstrap : unbound version constraints (>=4.0.0@alpha) should be avoided
require.bower-asset/font-awesome : unbound version constraints (*) should be avoided
require.yiisoft/yii2-authclient : unbound version constraints (*) should be avoided
require.yiisoft/yii2-swiftmailer : unbound version constraints (*) should be avoided
Что это может быть?
Спишь?

Gagins
Сообщения: 1
Зарегистрирован: 2017.06.09, 10:13

Re: Проблема при установке фреймворка

Сообщение Gagins » 2017.06.09, 10:19

Приподниму ветку.

Код: Выделить всё

Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery.inputmask ~3.2.2 -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery.inputmask ~3.2.2 -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery.inputmask ~3.2.2 -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery.inputmask 3.1.* -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery.inputmask 3.1.* -> no matching package found.
    - yiisoft/yii2 2.0.12 requires bower-asset/jquery.inputmask ~3.2.2 | ~3.3.5 -> no matching package found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery.inputmask ~3.2.2 | ~3.3.3 -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery.inputmask ~3.2.2 | ~3.3.3 -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery.inputmask ~3.2.2 | ~3.3.3 -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery.inputmask ~3.2.2 -> no matching package found.
    - Installation request for yiisoft/yii2 ~2.0.5 -> satisfiable by yiisoft/yii2[2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9]
.
Делал по инструкции https://nix-tips.ru/yii2-api-guides/gui ... ation.html
пробовал dev ветку ставить, та же ерунда.

Аватара пользователя
samdark
Администратор
Сообщения: 9186
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Проблема при установке фреймворка

Сообщение samdark » 2017.06.09, 11:53

Автор jquery.inputmask переименовал репу на GitHub :( Сейчас просит GitHub седалть алиас на старую.

zelenin
Сообщения: 10596
Зарегистрирован: 2013.04.20, 11:30

Re: Проблема при установке фреймворка

Сообщение zelenin » 2017.06.09, 11:54

забавно

Аватара пользователя
samdark
Администратор
Сообщения: 9186
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Проблема при установке фреймворка

Сообщение samdark » 2017.06.09, 13:15

Почти leftpad :)

itechman
Сообщения: 2
Зарегистрирован: 2018.06.18, 14:32

Re: Проблема при установке фреймворка

Сообщение itechman » 2019.11.09, 18:28

Всем привет!

Так как это обойти? Вручную?

При вызове на голом проекте

Код: Выделить всё

composer require yiisoft/yii2

Код: Выделить всё

- yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.4 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.3 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.29 requires bower-asset/jquery 3.4.*@stable | 3.3.*@stable | 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
И тд 42 записи.


Ответить