Не могу развернуть 2.0.7

Общие вопросы по использованию второй версии фреймворка. Если не знаете как что-то сделать и это про Yii 2, вам сюда.
Ответить
rebu
Сообщения: 28
Зарегистрирован: 2015.01.14, 14:13

Не могу развернуть 2.0.7

Сообщение rebu »

Добрый день.
Пробовал поставить Yii. Скачал composer. Пытаюсь добавить fxp/composer-asset-plugin - пишет

Код: Выделить всё

Installation failed, reverting ./composer.json to its original content.

                                                                          
  [ReflectionException]                                                   
  Class Fxp\Composer\AssetPlugin\Repository\NpmRepository does not exist  
                                                                          

                                                                                                                                                                                         
  [ErrorException]                                                                                                                                                                       
  Declaration of Fxp\Composer\AssetPlugin\Repository\AbstractAssetsRepository::whatProvides() should be compatible with Composer\Repository\ComposerRepository::whatProvides(Composer\D  
  ependencyResolver\Pool $pool, $name, $bypassFilters = false)                                                                                                                           
                                                                       
и изза этого не могу забрать Yii.
~/.composer чистил, даже удалял и заново качал композер - все тоже самое.
php 5.4.45 - на этом серваке раньше стоял 2.0.6 и все работало и вот тебе...
Никто не сталкивался с таким?

Аватара пользователя
girmate
Сообщения: 1533
Зарегистрирован: 2015.10.27, 12:52

Re: Не могу развернуть 2.0.7

Сообщение girmate »

Сталкивался, но я неправильно обновлял asset-plugin и поэтому при установке не ставился сам 2.0.7.
Осторожно! Вы общаетесь с новичком ;)

rebu
Сообщения: 28
Зарегистрирован: 2015.01.14, 14:13

Re: Не могу развернуть 2.0.7

Сообщение rebu »

и как решил вопрос?

Аватара пользователя
girmate
Сообщения: 1533
Зарегистрирован: 2015.10.27, 12:52

Re: Не могу развернуть 2.0.7

Сообщение girmate »

В самой команде была ошибка - неправильно написал ее.
Осторожно! Вы общаетесь с новичком ;)

bakhur
Сообщения: 202
Зарегистрирован: 2015.03.04, 10:56

Re: Не могу развернуть 2.0.7

Сообщение bakhur »

rebu писал(а):и как решил вопрос?
решили вопрос?

phpshko
Сообщения: 259
Зарегистрирован: 2015.03.21, 02:49

Re: Не могу развернуть 2.0.7

Сообщение phpshko »

Создавал проект тоже была ошибка. Помогла команда

Код: Выделить всё

composer global update fxp/composer-asset-plugin --no-plugins

jakiro
Сообщения: 553
Зарегистрирован: 2013.03.05, 15:15

Re: Не могу развернуть 2.0.7

Сообщение jakiro »

phpshko писал(а):Создавал проект тоже была ошибка. Помогла команда

Код: Выделить всё

composer global update fxp/composer-asset-plugin --no-plugins
Да, помогло
http://stackoverflow.com/questions/3643 ... g/36455086

Ответить