Почему такое отношение к Yii 2 у разработчиков?

Предварительное обсуждение найденных ошибок перед отправкой их авторам фреймворка, а также внесение новых предложений.
Ответить
YaOleg
Сообщения: 5
Зарегистрирован: 2020.05.12, 10:46

Почему такое отношение к Yii 2 у разработчиков?

Сообщение YaOleg »

Если честно, то меня расстраивает ситуация происходящая с фреймворком.

Захожу на страницу https://github.com/yiisoft/yii2-app-basic и читаю README.md:
The minimum requirement by this project template that your Web server supports PHP 5.6.0.
Открываю файл composer.json и вижу:

Код: Выделить всё

    "require": {
        "php": ">=7.4.0",
Устанавливаю через докер:

Код: Выделить всё

docker compose run --rm php composer.phar update --prefer-dist
и получаю ошибку:

Код: Выделить всё

  Problem 1
    - Root composer.json requires codeception/module-filesystem ^3.0 || ^1.1 -> satisfiable by codeception/module-filesystem[3.0.0].
    - codeception/module-filesystem 3.0.0 requires php ^8.0 -> your php version (7.4.30) does not satisfy that requirement.

Мало того что разработчики не могут определиться на какой версии PHP это должно работать 5, 7 или 8, так еще это лежит в репозитории уже месяц и всем плевать.

Почему так?
Может это кто нибудь поправит?
Аватара пользователя
ElisDN
Сообщения: 5822
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Почему такое отношение к Yii 2 у разработчиков?

Сообщение ElisDN »

YaOleg писал(а): 2022.09.25, 14:55 Почему так?
Yii2 многими заброшен. Все ждут и делают Yii3.

А вообще, для нового проекта всегда выбирайте самую свежую версию PHP. Сейчас это 8.1

Но есть риск, что сторонние компоненты от других авторов не будут работать с 8.1, так как авторы их забросили несколько лет назад. Их придётся форкать или править у себя в проекте небольшими костылями с переопределением функций или файлов.
YaOleg писал(а): 2022.09.25, 14:55 Может это кто нибудь поправит?
Форкните, поправьте и отправьте Pull Request.
Ответить