Тормозит PhpStorm 10 — у меня одного?

Темы, не касающиеся фреймворка, но относящиеся к программированию в целом.
Ответить
Аватара пользователя
resurtm
Сообщения: 299
Зарегистрирован: 2010.12.19, 09:13
Откуда: Казахстан, Алма-Ата
Контактная информация:

Тормозит PhpStorm 10 — у меня одного?

Сообщение resurtm » 2016.01.10, 15:58

Всем привет! :)

https://youtrack.jetbrains.com/issue/WI-30350 — кто-нибудь сталкивался с чем-нибудь подобным при переходе на PhpStorm 10? Девятка работает прекрасно.

В тикете по ссылке есть видео с демонстрацией бага. Интересно как пофиксить.

zelenin
Сообщения: 10596
Зарегистрирован: 2013.04.20, 11:30

Re: Тормозит PhpStorm 10 — у меня одного?

Сообщение zelenin » 2016.01.10, 19:36

честно говоря по видео не очень понятно как оно тормозит.
С седьмой версии обновлялся на каждую следующую версию поверх старой на двух ОСях (вин, линь) - все работает как часы.

Попробуйте очистить .WebIde\system в профиле - там всякие логи, локальная история, индексы итд - история пропадет, индексы пересоздадутся.
Может в плагинах дело - несовместимость там итд.

Аватара пользователя
samdark
Администратор
Сообщения: 9191
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Тормозит PhpStorm 10 — у меня одного?

Сообщение samdark » 2016.01.11, 14:57

У меня всё отлично. Я, правда, на винде и использую JDK из комплекта самого PHPStorm.

Аватара пользователя
resurtm
Сообщения: 299
Зарегистрирован: 2010.12.19, 09:13
Откуда: Казахстан, Алма-Ата
Контактная информация:

Re: Тормозит PhpStorm 10 — у меня одного?

Сообщение resurtm » 2016.01.11, 20:10

Спасибо товарищи! Это баг в JDK 8.

Вот эти опции запуска JVM помогли:

-Dawt.java2d.opengl=false
-Dsun.java2d.xrender=false

https://bugs.openjdk.java.net/browse/JDK-8068529
https://youtrack.jetbrains.com/issue/ID ... 27-1270907

Ответить