Голосуем за поддержку Yii в PhpStorm

Общие вопросы по использованию фреймворка. Если не знаете как что-то сделать и это про Yii, вам сюда.
Аватара пользователя
futbolim
Сообщения: 2051
Зарегистрирован: 2012.07.08, 19:28

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение futbolim »

Ура, товарищи!
Свершилось.
5-я версия шторма спрашивает разрешения сконфигурировать проект под Yii
Поздравляю всех!

Аватара пользователя
anton44eg
Сообщения: 2716
Зарегистрирован: 2012.01.25, 13:37
Откуда: Киев

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение anton44eg »

это пока еще невероятно криво. но да, процесс пошел! :)

lnghost
Сообщения: 134
Зарегистрирован: 2011.07.26, 18:05
Откуда: Воронеж
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение lnghost »

А где бы почитать, в чем заключается "конфигурирование под Yii"?
Конференция: yii@conference.jabber.ru Сайт: http://kamaran.ru

Аватара пользователя
samdark
Администратор
Сообщения: 9401
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение samdark »

Думаю, пока нигде.

yujin1st
Сообщения: 192
Зарегистрирован: 2012.03.26, 12:03

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение yujin1st »

Как понял они лишь добавили новую панель где отображаются все компоненты приложения... Или я что-то упустил? Поддержки getAttr, setAttr, поддержки путей в виджетах, в render() - ничего же в основном редакторе кода нет? Получается это некий переходный вариант, так ведь?

Аватара пользователя
samdark
Администратор
Сообщения: 9401
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение samdark »

Не, в редакторе кода пока ничего.

Аватара пользователя
GroZa
Сообщения: 180
Зарегистрирован: 2012.10.16, 17:00
Откуда: Сочи
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение GroZa »

Баг. Если создать файл Controller.php в проекте, то почему-то исчезает подсветка синтаксиса PHP.
Per aspera ad astra.

Аватара пользователя
samdark
Администратор
Сообщения: 9401
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение samdark »

Сюда http://youtrack.jetbrains.com/issues/WI надо про баги.

skit
Сообщения: 135
Зарегистрирован: 2012.10.08, 12:50
Откуда: Сибирь
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение skit »

Ага, в панели событий спросил про конфигурацию Yii, там я просто выбрал папку с фреймворком, нажал Apply вроде все. Eсть плагин поддержки структуры MVC для Simfony, куда и был добавлен Yii (Provides MVC structure information for framework-based projects. Currently supports Symfony 2 and Yii).
Конфигурацию можно изменить в Project settings -> Framework integration. Не так давно работаю с phpStorm, но видимо конфигурирование под Yii прошло автоматом после обновления шторма.

andreyrud
Сообщения: 265
Зарегистрирован: 2011.09.26, 14:59

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение andreyrud »

Это у меня одного с версии 129 триальный период перестал работать?

lynicidn
Сообщения: 2222
Зарегистрирован: 2014.05.24, 15:12

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение lynicidn »

andreyrud писал(а):Это у меня одного с версии 129 триальный период перестал работать?
через 30 дней? :lol:

lynicidn
Сообщения: 2222
Зарегистрирован: 2014.05.24, 15:12

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение lynicidn »

для yii2, такое еще не рассматривается ?

Аватара пользователя
GroZa
Сообщения: 180
Зарегистрирован: 2012.10.16, 17:00
Откуда: Сочи
Контактная информация:

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение GroZa »

Подскажите, пожалуйста, как работает Framework Integration. Я выставляю yii и ничего не происходит. Там какую-то папку выбрать надо?
Сам по себе phpstorm не определяет yii хоть он и находится в папке проекта. А вот symfony, например, определяет.
Да и вообще, много ли пользы от Framework Integration?
Per aspera ad astra.

andreyrud
Сообщения: 265
Зарегистрирован: 2011.09.26, 14:59

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение andreyrud »

lynicidn писал(а):
andreyrud писал(а):Это у меня одного с версии 129 триальный период перестал работать?
через 30 дней? :lol:
Нет. Следующая скаченая и установленная версия говорит ваша лицензия закончилась, хотя до конца 30 дней осталось еще много. Раньше помогала полное удаление предыдущей версии со всеми ее конфигами. 30 дней работали нормально. Теперь нет. Последнюю поставил сегодня, только настроил и алес... 30 дней у нее истекают 5 марта.

lynicidn
Сообщения: 2222
Зарегистрирован: 2014.05.24, 15:12

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение lynicidn »

andreyrud писал(а):
lynicidn писал(а):
andreyrud писал(а):Это у меня одного с версии 129 триальный период перестал работать?
через 30 дней? :lol:
Нет. Следующая скаченая и установленная версия говорит ваша лицензия закончилась, хотя до конца 30 дней осталось еще много. Раньше помогала полное удаление предыдущей версии со всеми ее конфигами. 30 дней работали нормально. Теперь нет. Последнюю поставил сегодня, только настроил и алес... 30 дней у нее истекают 5 марта.
винда гавно :roll: в линуксе все работает

andreyrud
Сообщения: 265
Зарегистрирован: 2011.09.26, 14:59

Re: Голосуем за поддержку Yii в PhpStorm

Сообщение andreyrud »

lynicidn писал(а): винда гавно :roll: в линуксе все работает
No .. you just misunderstood how it works.


EAP (Early Access Program) builds are free (have their own 30-day license) for major releases (e.g. 6.0, 7.0, 8.0) as they have lots of new/not-yet-polished code and features.

EAP builds for minor releases (e.g. 7.0.1, 7.1.3 etc) require proper valid license since they are mostly just a maintenance releases which mainly consists of bug fixes and other rather small improvements.

Summary:
Current EAP builds require valid license.
Once v8 EAP program will start, those EAP builds will be free.
After v8.0 final will be released, all subsequent EAP builds will once again require valid license.

Ответить