Страница 1 из 1

yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.07.07, 21:09
Driver86
https://github.com/yiisoft/yii2-bootstr ... nAsset.php

Код: Выделить всё

public $depends = [
     'yii\web\JqueryAsset',
Однако, https://github.com/yiisoft/yii2/blob/3. ... UPGRADE.md
('yii\web\JqueryAsset' был перемещён в 'yii\jquery\JqueryAsset')

Из-за этого ошибка "Class yii\web\JqueryAsset not found..."

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.07.08, 00:04
ElisDN
Да, так как это Yii3 и Yii2-bootstrap.

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.07.08, 10:54
Driver86
https://github.com/yiisoft/yii2-bootstr ... r.json#L39

Код: Выделить всё

"require": {
        "yiisoft/yii2": "~2.0|~2.1@dev|~3.0@dev",
yii2-bootstrap4 в требованиях допускает yii 3.
И что-то я малость запутался в версиях.
Где yii 2.1? Я его не вижу на гитхабе. Выглядит, как будто yii2.1 === yii3.0

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.07.08, 11:32
skynin
Ferro7 писал(а):
2018.07.08, 10:54
Где yii 2.1? Я его не вижу на гитхабе. Выглядит, как будто yii2.1 === yii3.0
Yii development notes #23
Jun 30
There will be no Yii 2.1
Yii officially adopts SemVer since next major version that would be called 3.0. Stable 2.0 versions are staying as is in they numbering schema.
https://www.patreon.com/posts/yii-development-19759260

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.07.09, 15:13
Driver86
Насчёт вопроса: бутрсап4 есть второй версии - его и надо использовать.
Решено.

Re: yii2 версии 3 и yii2-bootstrap4 несовместимы

Добавлено: 2018.08.19, 11:05
mkramer
3 версия ещё даже не в beta, её только поиграться ставить или последить/поучаствовать в разработке