Не могу установить samdark/yii2-shop

Общие вопросы по использованию второй версии фреймворка. Если не знаете как что-то сделать и это про Yii 2, вам сюда.
Ответить
Аватара пользователя
webplus
Сообщения: 264
Зарегистрирован: 2012.02.24, 22:05
Контактная информация:

Не могу установить samdark/yii2-shop

Сообщение webplus » 2019.11.14, 18:22

Здравствуйте!
Пытаюсь установить https://github.com/samdark/yii2-shop
вот что пишет в консоли:

Код: Выделить всё

pavel@pavel-desktop:~/www/yii2-shop$ sudo composer self-update
You are already using composer version 1.9.1 (stable channel).

pavel@pavel-desktop:~/www/yii2-shop$ sudo composer global require "fxp/composer-asset-plugin:~1.1.1"
[sudo] пароль для pavel: 
Changed current directory to /home/pavel/.composer
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing fxp/composer-asset-plugin (v1.1.4): Loading from cache
Writing lock file
Generating autoload files
                                                    
pavel@pavel-desktop:~/www/yii2-shop$ sudo composer install
[sudo] пароль для pavel: 
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for yiisoft/yii2-composer 2.0.3 -> satisfiable by yiisoft/yii2-composer[2.0.3].
    - yiisoft/yii2-composer 2.0.3 requires composer-plugin-api 1.0.0 -> no matching package found.
  Problem 2
    - yiisoft/yii2-composer 2.0.3 requires composer-plugin-api 1.0.0 -> no matching package found.
    - yiisoft/yii2 2.0.3 requires yiisoft/yii2-composer * -> satisfiable by yiisoft/yii2-composer[2.0.3].
    - Installation request for yiisoft/yii2 2.0.3 -> satisfiable by yiisoft/yii2[2.0.3].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

unknownby
Сообщения: 35
Зарегистрирован: 2019.11.05, 16:34

Re: Не могу установить samdark/yii2-shop

Сообщение unknownby » 2019.11.15, 08:50

Может попробовать без sudo для начала?

Код: Выделить всё

pavel@pavel-desktop:~/www/yii2-shop$ composer global require "fxp/composer-asset-plugin:~1.1.1"
Вроде как пишет же даже.

Код: Выделить всё

Do not run Composer as root/super user!

Ответить