Ошибка при установке yii2-fontawesome ~3.3 потомучто yii2-adminlte уже установил пакет yii2-fontawesome ~2.9

Общие вопросы по использованию второй версии фреймворка. Если не знаете как что-то сделать и это про Yii 2, вам сюда.
Ответить
alexa777
Сообщения: 280
Зарегистрирован: 2016.03.01, 17:38

Ошибка при установке yii2-fontawesome ~3.3 потомучто yii2-adminlte уже установил пакет yii2-fontawesome ~2.9

Сообщение alexa777 » 2019.02.14, 09:15

Пытаюсь установить yii2-fontawesome ~3.3 но composer выдает ошибку
Problem 1
- The requested package rmrevin/yii2-fontawesome ~3.3 is satisfiable by rmrevin/yii2-fontawesome[3.x-dev] but these conflict with your requirements or minimum-stability.
Problem 2
- dmstr/yii2-adminlte-asset 2.6.2 requires rmrevin/yii2-fontawesome ~2.9 -> satisfiable by rmrevin/yii2-fontawesome[2.10.0, 2.10.1, 2.10.2, 2.10.3, 2.11.0, 2.12.0, 2.12.1, 2.12.2, 2.13.0, 2.14.0, 2.15.0, 2.15.1, 2.15.2, 2.16.0, 2.16.1, 2.17.0, 2.17.1, 2.9.0, 2.9.1, 2.9.2, 2.x-dev] but these conflict with your requirements or minimum-stability.
Как его установить?

Loveorigami
Сообщения: 971
Зарегистрирован: 2014.08.27, 21:54

Re: Ошибка при установке yii2-fontawesome ~3.3 потомучто yii2-adminlte уже установил пакет yii2-fontawesome ~2.9

Сообщение Loveorigami » 2019.02.14, 19:39

Так написано же

dmstr/yii2-adminlte-asset 2.6.2 requires rmrevin/yii2-fontawesome ~2.9

А ты ставишь rmrevin/yii2-fontawesome ~3.3

Либо первый пакет убирай, либо второй.

alexa777
Сообщения: 280
Зарегистрирован: 2016.03.01, 17:38

Re: Ошибка при установке yii2-fontawesome ~3.3 потомучто yii2-adminlte уже установил пакет yii2-fontawesome ~2.9

Сообщение alexa777 » 2019.02.19, 16:21

Loveorigami писал(а):
2019.02.14, 19:39
Так написано же

dmstr/yii2-adminlte-asset 2.6.2 requires rmrevin/yii2-fontawesome ~2.9

А ты ставишь rmrevin/yii2-fontawesome ~3.3

Либо первый пакет убирай, либо второй.
Говорить легко, а Вы попробуйте сделайте. adminlte использует пакет yii2-fontawesome ~2.9 и хоть кол на лбу чеши и удаляй yii2-fontawesome ~2.9 то при установке yii2-fontawesome ~3.3 выдает туже ошибку что adminlte нужен yii2-fontawesome ~2.9

Loveorigami
Сообщения: 971
Зарегистрирован: 2014.08.27, 21:54

Re: Ошибка при установке yii2-fontawesome ~3.3 потомучто yii2-adminlte уже установил пакет yii2-fontawesome ~2.9

Сообщение Loveorigami » 2019.02.19, 17:21

Я пробовать и не буду, я знаю. Поэтому и написал, что Вам нужно выбрать одно из двух.
Либо первый пакет убирай, либо второй.
А если нужен 3.3 в dmstr/yii2-adminlte-asset - пишите issue (PR) разработчику dmstr/yii2-adminlte-asset.
Он не реагирует - делаете форк к себе, меняете, как хотите. Прописываете в composere путь к своему пакету.

Но учтите - нет гарантии, что dmstr/yii2-adminlte-asset 2.6.2 будет хорошо работать с yii2-fontawesome ~3.3.
Все это Вы делаете на свой страх и риск.

Ответить