При переносе проекта с локального на хостинг проблема

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
Alex80
Сообщения: 21
Зарегистрирован: 2015.04.10, 16:40

При переносе проекта с локального на хостинг проблема

Сообщение Alex80 » 2019.04.30, 13:14

Всем привет!

Кто может помочь с такой проблемой?

Старый проект нормально работал, написан был на Yii 2.0.6.
Перестроил проект и закинул на сервер уже с Yii 2.0.18.

Выпадает ошибка

Код: Выделить всё

Parse error: syntax error, unexpected 'function' (T_FUNCTION), expecting identifier (T_STRING) or \\ (T_NS_SEPARATOR) in /home/xxxxx/xxxxxx.com/www/basic/vendor/myclabs/deep-copy/src/DeepCopy/deep_copy.php on line 5
Как нынче решается проблема?

Посмотрел много добавлений в папке vendor.
В Yii 2.0.6. нет папки myclabs и файла deep_copy.php
Как то по особому разворачивают проекты на хостинге?
На localhost вообще проблем нет, работает отлично, что на хосте php 7.3 что и на localhoste.


Всем спасибо за помощь.

Аватара пользователя
samdark
Администратор
Сообщения: 9196
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: При переносе проекта с локального на хостинг проблема

Сообщение samdark » 2019.04.30, 13:42

DeepCopy — это не зависимость Yii. Это что-то у вас в проекте.

Alex80
Сообщения: 21
Зарегистрирован: 2015.04.10, 16:40

Re: При переносе проекта с локального на хостинг проблема

Сообщение Alex80 » 2019.04.30, 13:51

Может на хостинге, какие то настройки поменять. Я чистый yii 2.0.18 заливаю тоже ошибка. Ставлю старый, нет ошибки. Феномен. На локальной проблем нет.

Alex80
Сообщения: 21
Зарегистрирован: 2015.04.10, 16:40

Re: При переносе проекта с локального на хостинг проблема

Сообщение Alex80 » 2019.04.30, 13:53

Чистый я имею ввиду без моего кода, только секретный код вписываюсь в web.php.

Alex80
Сообщения: 21
Зарегистрирован: 2015.04.10, 16:40

Re: При переносе проекта с локального на хостинг проблема

Сообщение Alex80 » 2019.04.30, 15:28

Нашел проблему, на хосте стоял php 5.4, поставил php 7.3. Заработало, большое спасибо.

Ответить