Проблема установки advanced CENTOS7 !

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
kastorm
Сообщения: 8
Зарегистрирован: 2015.11.13, 00:23

Проблема установки advanced CENTOS7 !

Сообщение kastorm » 2019.02.11, 01:21

Все день добрый,
Проблема с установкой advanced на ISPmanager CENTOS7
Сама ошибка :

Код: Выделить всё

Last login: Mon Feb 11 00:44:38 MSK 2019 on pts/0                                                                                                                               
-bash-4.2$ composer create-project --prefer-dist yiisoft/yii2-app-advanced /var/www/kastor/data/www/www                                                                         
Peer fingerprint did not match
https://repo.packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
Installing yiisoft/yii2-app-advanced (2.0.16)
  - Installing yiisoft/yii2-app-advanced (2.0.16): Loading from cache
Created project in /var/www/kastor/data/www/www
Loading composer repositories with package information
Peer fingerprint did not match
https://repo.packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
                                                                                                                                                                                
  Problem 1                                                                                                                                                                     
    - Installation request for codeception/verify ~1.0.0 -> satisfiable by codeception/verify[1.0.0].                                                                           
    - codeception/verify 1.0.0 requires php >= 7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                              
  Problem 2                                                                                                                                                                     
    - phpunit/phpunit 6.5.9 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                   
    - phpunit/phpunit 6.5.8 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                   
    - phpunit/phpunit 6.5.7 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                   
    - phpunit/phpunit 6.5.6 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                   
    - phpunit/phpunit 6.5.5 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                   
    - phpunit/phpunit 6.5.14 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                  
    - phpunit/phpunit 6.5.13 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                  
    - phpunit/phpunit 6.5.12 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                  
    - phpunit/phpunit 6.5.11 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                  
    - phpunit/phpunit 6.5.10 requires php ^7.0 -> your PHP version (5.4.16) does not satisfy that requirement.                                                                  
    - Installation request for phpunit/phpunit ~6.5.5 -> satisfiable by phpunit/phpunit[6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9].             
                                                                                                                                                                                
-bash-4.2$     
Версию CENTOS7 по умолчанию идет 5.4 обновить не получается, каким образом можно обойти данную проблему,
За ранее всем спасибо.


kastorm
Сообщения: 8
Зарегистрирован: 2015.11.13, 00:23

Re: Проблема установки advanced CENTOS7 !

Сообщение kastorm » 2019.02.11, 16:37

Спасибо , заработало . :mrgreen:
Тока как сейчас себя ispmanager будет вести не известно.

Аватара пользователя
SiZE
Сообщения: 2698
Зарегистрирован: 2011.09.21, 12:39
Откуда: Perm
Контактная информация:

Re: Проблема установки advanced CENTOS7 !

Сообщение SiZE » 2019.02.11, 17:09

kastorm писал(а):
2019.02.11, 16:37
Спасибо , заработало . :mrgreen:
Тока как сейчас себя ispmanager будет вести не известно.
ispmanager помоему уже умеет даже 7.3 но я эту говнопанель не люблю.
в поиске работы

Ответить