Как установить конкретную версию Yii2?

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
baursak
Сообщения: 4
Зарегистрирован: 2018.04.06, 17:55

Как установить конкретную версию Yii2?

Сообщение baursak » 2018.04.06, 17:59

Добрый всем день

мне для учебы нужно развернуть Yii 2.0.7

выполняю последовательно в Git Bash внутри папки будущего домена:

composer self-update
composer global require "fxp/composer-asset-plugin:1.4.2"
composer create-project yiisoft/yii2-app-basic . 2.0.7

но после установки в браузере внизу страницы вижу 2.0.15.1

куда копать ?

andku83
Сообщения: 665
Зарегистрирован: 2016.07.01, 10:24
Откуда: Харьков

Re: Как установить конкретную версию Yii2?

Сообщение andku83 » 2018.04.06, 20:04

Код: Выделить всё

composer create-project yiisoft/yii2-app-basic . 2.0.7 --no-install
открыть composer.json

Код: Выделить всё

        "yiisoft/yii2": ">=2.0.5",
изменить на:

Код: Выделить всё

        "yiisoft/yii2": "2.0.7",

Код: Выделить всё

composer install

baursak
Сообщения: 4
Зарегистрирован: 2018.04.06, 17:55

Re: Как установить конкретную версию Yii2?

Сообщение baursak » 2018.04.06, 20:12

Спасибо.
Вот, только у меня еще и PHP v7.2.3 стоит. И откатываться на 5.6 не хотелось бы.
А в случае PHP >=7.0 вроде такая ошибка у людей вылетает:
"Fatal error: Cannot use 'Object' as class name as it is reserved in /public_html/vendor/yiisoft/yii2/base/Object.php on line 77" .
Т.е. не судьба, и надо ставить вместо 2.0.7 как максимум 2.0.13 ? Или еще что-то придумать можно?

Аватара пользователя
samdark
Администратор
Сообщения: 8793
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Как установить конкретную версию Yii2?

Сообщение samdark » 2018.04.06, 20:25

Нет, придумать ничего нельзя. Либо используйте старые версии PHP, либо новые версии Yii.

baursak
Сообщения: 4
Зарегистрирован: 2018.04.06, 17:55

Re: Как установить конкретную версию Yii2?

Сообщение baursak » 2018.04.06, 20:40

Спасибо.
Выполнил composer ... --no-install
И сделал как тут (почти как тут, вот только "yiisoft/yii2": "2.0.13" зафиксировал без тильды):
https://www.it-rem.ru/yii2-fatal-error- ... -name.html
Установилась 2.0.13
Но я не суеверен :)
Хороших всем выходных

andku83
Сообщения: 665
Зарегистрирован: 2016.07.01, 10:24
Откуда: Харьков

Re: Как установить конкретную версию Yii2?

Сообщение andku83 » 2018.04.06, 23:25

то что я писал выше (установку) делал на 7.1.~
запускать приложение не пробовал

baursak
Сообщения: 4
Зарегистрирован: 2018.04.06, 17:55

Re: Как установить конкретную версию Yii2?

Сообщение baursak » 2018.04.07, 13:23

Спасибо.
А как сейчас поступают те, кто делал проект на PHP v5.x и Yii v2.0.7, а сейчас решили проапгрейдить для проекта и PHP и Yii2 ?
Или просто "заморозили" версии ?

Nex-Otaku
Сообщения: 809
Зарегистрирован: 2016.07.09, 21:07

Re: Как установить конкретную версию Yii2?

Сообщение Nex-Otaku » 2018.04.09, 20:51

baursak писал(а):
2018.04.07, 13:23
Спасибо.
А как сейчас поступают те, кто делал проект на PHP v5.x и Yii v2.0.7, а сейчас решили проапгрейдить для проекта и PHP и Yii2 ?
Или просто "заморозили" версии ?
Берёшь и апгрейдишь.

Аватара пользователя
ElisDN
Сообщения: 4997
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Как установить конкретную версию Yii2?

Сообщение ElisDN » 2018.04.10, 11:52

baursak писал(а):
2018.04.07, 13:23
А как сейчас поступают те, кто делал проект на PHP v5.x и Yii v2.0.7, а сейчас решили проапгрейдить для проекта и PHP и Yii2 ?
Читают CHANGELOG и апгрейдят либо сразу с 2.0.7 на 2.0.15, либо постепенно 2.0.7 -> 2.0.8 -> ... -> 2.0.15.

Если есть тесты, то после обновления структуры папки tests с убиранием заброшенного yii2-codeception всё идёт без проблем. Если тестов нет, то как повезёт.

Ответить