YII Перенос блога модуля в yii2- как решить ошибку?

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

YII Перенос блога модуля в yii2- как решить ошибку?

Сообщение Fin »

после переноса блога из backand/common/modules в vendor как отдельный модуль на site.com/blog выдаёт 404 Изображение
Изображение

Loveorigami
Сообщения: 975
Зарегистрирован: 2014.08.27, 21:54

Re: YII Перенос блога модуля в yii2- как решить ошибку?

Сообщение Loveorigami »

Подробнее напишите порядок действий при переносе в vendor.
В особенности, что делали с namespace и как потом прописывали их в config - e.
Если просто, как пишите, "перенесли" - то отсюда и результат.

Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

Re: YII Перенос блога модуля в yii2- как решить ошибку?

Сообщение Fin »

Разобрался в чем дело - в одном месте не указан был namespace, но вот с тэгами так и непонятно..
При нажатии на 'Тэги' в админ.панеле выдаёт 404 по адресу http://admin.site.com/tag

Изображение

Loveorigami
Сообщения: 975
Зарегистрирован: 2014.08.27, 21:54

Re: YII Перенос блога модуля в yii2- как решить ошибку?

Сообщение Loveorigami »

Это Вы показываете результат, а не следствие... Надо установить место, где это ломатся...

По аналогии... Начинаете с UrlManager-a, на какой модуль идет запрос.
В модуле проверяете action, правила доступа (access filter, кажется...) ну и потом смотрите сам код. Есть ли return и тп...

Ответить