Ошибка установки виджета Select2 через Composer -как исправить?

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Fin » 2017.07.08, 16:34

Пробую установить Select2 сначала через консоль Open Server - вообще не устанавливает:
user@DESKTOP-OKASEM6 D:\sites\site\yii2
$ composer require kartik-v/yii2-widget-select2 "@dev"
user@DESKTOP-OKASEM6 D:\sites\site\yii2
$
а через Gitbush выдает ошибку: [/img]https://habrastorage.org/web/608/494/6c ... 891ebc.jpg[/img]
Composer.json ( D:sites\site\yii2)

Код: Выделить всё

{
    "name": "yiisoft/yii2-app-advanced",
    "description": "Yii 2 Advanced Project Template",
    "keywords": ["yii2", "framework", "advanced", "project template"],
    "homepage": "http://www.yiiframework.com/",
    "type": "project",
    "license": "BSD-3-Clause",
    "support": {
        "issues": "https://github.com/yiisoft/yii2/issues?state=open",
        "forum": "http://www.yiiframework.com/forum/",
        "wiki": "http://www.yiiframework.com/wiki/",
        "irc": "irc://irc.freenode.net/yii",
        "source": "https://github.com/yiisoft/yii2"
    },
    "minimum-stability": "stable",
    "require": {
        "php": ">=5.4.0",
        "yiisoft/yii2": "~2.0.6",
        "yiisoft/yii2-bootstrap": "~2.0.0",
        "yiisoft/yii2-swiftmailer": "~2.0.0",
        "vova07/yii2-imperavi-widget": "*",
        "dmstr/yii2-adminlte-asset": "2.*"
    },
    "require-dev": {
        "yiisoft/yii2-debug": "~2.0.0",
        "yiisoft/yii2-gii": "~2.0.0",
        "yiisoft/yii2-faker": "~2.0.0",

        "codeception/base": "^2.2.3",
        "codeception/verify": "~0.3.1"
    },
    "config": {
        "process-timeout": 1800,
        "fxp-asset":{
            "installer-paths": {
                "npm-asset-library": "vendor/npm",
                "bower-asset-library": "vendor/bower"
            }
        }
    }
}

Если пробую устанавливать другим способом выдает такую ошибку:Изображение

Или это, если устанавливать что-то другое:

Изображение

Если в composer.json менять: "minimum-stability":"stable" на "minimum-stability": "dev"- то, все ровно ничего не меняется(

Nex-Otaku
Сообщения: 825
Зарегистрирован: 2016.07.09, 21:07

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Nex-Otaku » 2017.07.08, 18:35

funsion? katrik? Gitbush??? )))

Внимательнее набирайте, без опечаток )

Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Fin » 2017.07.08, 19:09

Да, именно katrik- на странице загрузки такой код : $ php composer.phar require kartik-v/yii2-widget-select2 "@dev"
Изображение


другой вот установился, a select2- нет..пробовал обновить, "--no plugins" - не помогло Изображение

Nex-Otaku
Сообщения: 825
Зарегистрирован: 2016.07.09, 21:07

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Nex-Otaku » 2017.07.08, 19:44

Не знаю на какой странице загрузки вы смотрите, везде всегда было "kartik" а не "katrik".

Вот и здесь так же: https://github.com/kartik-v/yii2-widget-select2

А вообще рекомендую пользоваться старым добрым приёмом "копировать-вставить". Консоль композера это замечательно поддерживает.
Последний раз редактировалось Nex-Otaku 2017.07.08, 19:47, всего редактировалось 1 раз.

Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Fin » 2017.07.08, 19:47

Все разобрался, спасибо) да, правильно: "kartik" :) тема закрыта!
Последний раз редактировалось Fin 2017.07.08, 19:54, всего редактировалось 1 раз.

Nex-Otaku
Сообщения: 825
Зарегистрирован: 2016.07.09, 21:07

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Nex-Otaku » 2017.07.08, 19:48

Ну и прочитайте внимательно. Разница в том, что вы порядок букв перепутали.

Fin
Сообщения: 13
Зарегистрирован: 2017.06.18, 13:28

Re: Ошибка установки виджета Select2 через Composer -как исправить?

Сообщение Fin » 2017.07.08, 19:58

У меня в Gitbash ещё не работает копирование, только вручную, а в консоли OpenServer - вообще команды не работают. Набираешь user@DESKTOP-OKASEM6 D:\sites\site\yii2
$ composer require kartik-v/yii2-widget-select2 "@dev"
user@DESKTOP-OKASEM6 D:\sites\site\yii2
$
и всё..

Ответить