Помогите обновить Yii2 через composer.

Различные вопросы по установке и настройке фреймворка, конфигурции веб-сервера и IDE.
Ответить
remix
Сообщения: 59
Зарегистрирован: 2018.01.01, 18:24

Помогите обновить Yii2 через composer.

Сообщение remix »

Всем, привет. Всех поздравляю с новым 2018 годом! Новых побед и огромных успехов в жизни!

А теперь по делу:
Я новичок в Yii2 но пересмотрел все сообщения на этом форуме, искал в интернете и как я понял, чтобы обновить мой Yii2 проект мне нужно в composer указать адрес где лежит мой сайт Yii2 на openserver и находясь в этой ветке набрать: composer update и Yii2 должен обновится. Но чего то мой Yii2 не обновляется, не могу понять почему?...

Ребята прошу вашей помощи и поддержки. Что мне нужно написать, чтобы обновить мой проект?
Версия моего Yii2 проекта 2.0.10 - хотелось бы обновиться до последней 2.0.13. Как я понимаю я чего-то не дописываю. И еще, я пытался удалять папку Vendor и файл composer.lock Но эти действия не помогли.

Вот ошибка в composer:

Код: Выделить всё

gm@REMIX C:\OpenServer\domains\yii2.loc
> composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13.1 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.13 requires bower-asset/jquery 3.2.*@stable | 3.1.*@stable | 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.12 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 ~2.0.5 -> satisfiable by yiisoft/yii2[2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.13, 2.0.13.1, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
Для большей наглядности выкладываю мой файл composer.json

Код: Выделить всё

{
    "name": "yiisoft/yii2-app-basic",
    "description": "Yii 2 Basic Project Template",
    "keywords": ["yii2", "framework", "basic", "project template"],
    "homepage": "http://www.yiiframework.com/",
    "type": "project",
    "license": "BSD-3-Clause",
    "support": {
        "issues": "https://github.com/yiisoft/yii2/issues?state=open",
        "forum": "http://www.yiiframework.com/forum/",
        "wiki": "http://www.yiiframework.com/wiki/",
        "irc": "irc://irc.freenode.net/yii",
        "source": "https://github.com/yiisoft/yii2"
    },
    "minimum-stability": "stable",
    "require": {
        "php": ">=5.4.0",
        "yiisoft/yii2": "~2.0.5",
        "yiisoft/yii2-bootstrap": "~2.0.0",
        "yiisoft/yii2-swiftmailer": "~2.0.0",
        "mihaildev/yii2-ckeditor": "*",
        "mihaildev/yii2-elfinder": "*",
        "costa-rico/yii2-images": "dev-master",
        "phpnt/yii2-export": "*"
    },
    "require-dev": {
        "yiisoft/yii2-debug": "~2.0.0",
        "yiisoft/yii2-gii": "~2.0.0",
        "yiisoft/yii2-faker": "~2.0.0",

        "codeception/base": "^2.2.3",
        "codeception/verify": "~0.3.1",
        "codeception/specify": "~0.4.3"
    },
    "config": {
        "process-timeout": 1800
    },
    "scripts": {
        "post-create-project-cmd": [
            "yii\\composer\\Installer::postCreateProject"
        ]
    },
    "extra": {
        "yii\\composer\\Installer::postCreateProject": {
            "setPermission": [
                {
                    "runtime": "0777",
                    "web/assets": "0777",
                    "yii": "0755"
                }
            ],
            "generateCookieValidationKey": [
                "config/web.php"
            ]
        },
        "asset-installer-paths": {
            "npm-asset-library": "vendor/npm",
            "bower-asset-library": "vendor/bower"
        }
    }
}

Аватара пользователя
samdark
Администратор
Сообщения: 9444
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Помогите обновить Yii2 через composer.

Сообщение samdark »

1. composer global install fxp/composer-asset-plugin
2. Удалить vendor.
3. Повторить то, что делали.

remix
Сообщения: 59
Зарегистрирован: 2018.01.01, 18:24

Re: Помогите обновить Yii2 через composer.

Сообщение remix »

Спасибо большое помогло!

Хотя изначально сделал вашу команду и не понял, ничего не поменялось, а вышла ошибка... Потом все же сделал обновление и YII2 обновился. Обновления прошли до 2.0.12 версии Yii2.

Код: Выделить всё

gm@REMIX c:\openserver
> cd C:\OpenServer\domains\yii2.loc

gm@REMIX C:\OpenServer\domains\yii2.loc
> composer global install fxp/composer-asset-plugin
Changed current directory to C:/Users/gm/AppData/Roaming/Composer
Invalid argument fxp/composer-asset-plugin. Use "composer require fxp/composer-asset-plugin" instead
to add packages to your composer.json.

gm@REMIX C:\OpenServer\domains\yii2.loc
> cd  C:/Users/gm/AppData/Roaming/Composer

gm@REMIX C:\Users\gm\AppData\Roaming\Composer
> composer global install fxp/composer-asset-plugin
Changed current directory to C:/Users/gm/AppData/Roaming/Composer
Invalid argument fxp/composer-asset-plugin. Use "composer require fxp/composer-asset-plugin" instead to add packages to your composer.jso
n.

gm@REMIX C:\Users\gm\AppData\Roaming\Composer
> cd C:\OpenServer\domains\yii2.loc

gm@REMIX C:\OpenServer\domains\yii2.loc
> composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 10 installs, 40 updates, 0 removals
  - Updating swiftmailer/swiftmailer (v5.4.5 => v5.4.8): Downloading (100%)
  - Updating ezyang/htmlpurifier (v4.8.0 => v4.9.3): Downloading (100%)
  - Updating cebe/markdown (1.1.1 => 1.1.2): Downloading (100%)
  - Updating yiisoft/yii2 (2.0.10 => 2.0.12): Downloading (100%)
  - Updating yiisoft/yii2-swiftmailer (2.0.6 => 2.0.7): Downloading (100%)
  - Updating yiisoft/yii2-bootstrap (2.0.6 => 2.0.7): Downloading (100%)
  - Updating yiisoft/yii2-debug (2.0.7 => 2.0.12): Downloading (100%)


remix
Сообщения: 59
Зарегистрирован: 2018.01.01, 18:24

Re: Помогите обновить Yii2 через composer.

Сообщение remix »

Сделал заново с require и обновил Yii2 до версии 2.0.13.1

Спасибо большое.

clondayk
Сообщения: 16
Зарегистрирован: 2011.08.31, 21:21

Re: Помогите обновить Yii2 через composer.

Сообщение clondayk »

Добрый день.
Подскажите знающие люди.
Есть demo-сервер с PHP5.6.
Разработка ведется локально и для проверки через jenkins git ветка загружается на demo-сервер.
Но в jenkins задаче submodule обновляются автоматически и сейчас появилась проблема, т.к. некоторые kartik стали не совместимы с php5.6.

Подскажите можно ли как-то задать параметры для git, чтобы обновлялся не выше какой-то ревизии?

Ответить