Yii2-user

Выкладываем свои наработки
kutuev93
Сообщения: 75
Зарегистрирован: 2016.01.24, 18:15
Откуда: Тюмень

Re: Yii2-user

Сообщение kutuev93 » 2016.01.29, 16:04

vitaxa_prog писал(а):
kutuev93 писал(а): Мне хотелось бы сделать авторизацию через всплывающее окно. Сейчас авторизация реализуется через экшен login.
Ничего пока умного не пришло в голову как:
В документации написано, что можно всё переопределять. Я бы посоветовал вам унаследовать нужные части от yii-user. Я у себя в проекте так и сделал. И все прекрасно работает.
Спасибо за ответ!

Но не могли бы дать комментарий по этому поводу. Что в данном случае вы бы переопределили?
По сути родной контроллер и экшн я трогать не буду. Пусть страница входа будет по умолчанию.

В виджете же будет логика текущего контроллера (копипаст) + отдельно я создам вьюху с самой формой (в своем месте).

Я бы согласился, если бы мне нужно было бы добавить поле и прочее, тогда да, унаследоваться было бы самое лучшее решение. Я с архитектурой yii2 не знаком, базовых и так сказать оптимальных решений не знаю.

Заранее спасибо!

Аватара пользователя
vitaxa_prog
Сообщения: 297
Зарегистрирован: 2011.06.06, 22:44
Откуда: Волноваха

Re: Yii2-user

Сообщение vitaxa_prog » 2016.01.31, 14:02

kutuev93 писал(а):Но не могли бы дать комментарий по этому поводу. Что в данном случае вы бы переопределили?
По сути родной контроллер и экшн я трогать не буду. Пусть страница входа будет по умолчанию.
Не знаю вашей задачи, потому не могу что то посоветовать. Судя по всему вам нужен просто виджет с формой. Форма отправляет данные на user/security/login и всё. В виджете логика вообще не нужна.
В принципе ничего нет невозможного.
— Вы думаете?
— Для человека. С интеллектом.

Аватара пользователя
oleg1
Сообщения: 72
Зарегистрирован: 2013.10.23, 15:13

Re: Yii2-user

Сообщение oleg1 » 2016.04.21, 16:01

подскажите, вход через социальные сети не реализован до конца ?

thecoder
Сообщения: 87
Зарегистрирован: 2014.10.19, 18:55

Re: Yii2-user

Сообщение thecoder » 2016.04.29, 22:13

Ребята помогите с установкой расширения.
Yii2 установлен заново (advanced), установлен yii2-user.
В common/config/main.php добавил

Код: Выделить всё

'modules' => [
        'user' => [
            'class' => 'dektrium\user\Module',
        ],
    ], 
Почему пишем \user ведь при установке расширение ставится в yii2-user?

При клике по ссылке SignUp или Login выполняется класс по умолчанию.
В components пишу

Код: Выделить всё

'user' => [
            'identityClass' => 'dektrium\yii2-user\models\User',
            'enableAutoLogin' => true,
        ], 
не помогает.

Если писать

Код: Выделить всё

'identityClass' => 'dektrium\yii2-user\models\User', 
эффект тот же.

Подскажите как его использовать.

Аватара пользователя
ElisDN
Сообщения: 4590
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Yii2-user

Сообщение ElisDN » 2016.04.30, 09:35

thecoder писал(а):Почему пишем \user ведь при установке расширение ставится в yii2-user?

Подскажите как его использовать.
Потому что это namespace, а не имя папки расширения. Использовать аналогично dektrium\user\models\User.
Не забудьте пройти мастер-класс по Yii2.

Notad
Сообщения: 57
Зарегистрирован: 2015.10.03, 16:30

Re: Yii2-user

Сообщение Notad » 2016.07.05, 02:38

Добрый день. А модуль регистрации для одноклассников не планируется?

faeton
Сообщения: 88
Зарегистрирован: 2011.06.06, 01:00

Re: Yii2-user

Сообщение faeton » 2016.07.05, 04:12

https://github.com/simplator/user/tree/master/clients
там несколько гетеров убрать надо будет а так все работает :)
Изображение

Аватара пользователя
Sergalas
Сообщения: 594
Зарегистрирован: 2015.10.15, 12:39

Re: Yii2-user

Сообщение Sergalas » 2016.07.06, 16:34

Проблема при установке на php 7

Код: Выделить всё

Problem 1
    - dektrium/yii2-user 0.9.6 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.0 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.1 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.2 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.3 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.4 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - dektrium/yii2-user v0.9.5 requires yiisoft/yii2-authclient ~2.0 -> satisfiable by yiisoft/yii2-authclient[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
    - yiisoft/yii2-authclient 2.0.5 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - yiisoft/yii2-authclient 2.0.4 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - yiisoft/yii2-authclient 2.0.3 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - yiisoft/yii2-authclient 2.0.2 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - yiisoft/yii2-authclient 2.0.1 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - yiisoft/yii2-authclient 2.0.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.
    - Installation request for dektrium/yii2-user 0.9.*@dev -> satisfiable by dektrium/yii2-user[0.9.6, v0.9.0, v0.9.1, v0.9.2, v0.9.3, v0.9.4, v0.9.5].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-mysqlnd.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/15-xml.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-dom.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gd.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-mbstring.ini
    - /etc/php/7.0/cli/conf.d/20-mcrypt.ini
    - /etc/php/7.0/cli/conf.d/20-mysqli.ini
    - /etc/php/7.0/cli/conf.d/20-pdo_mysql.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-simplexml.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
    - /etc/php/7.0/cli/conf.d/20-wddx.ini
    - /etc/php/7.0/cli/conf.d/20-xmlreader.ini
    - /etc/php/7.0/cli/conf.d/20-xmlwriter.ini
    - /etc/php/7.0/cli/conf.d/20-xsl.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
 
думал с переходам на php 5.6. что то изменится не изменилось
только поменялось php/5.6/cli

zelenin
Сообщения: 10099
Зарегистрирован: 2013.04.20, 11:30

Re: Yii2-user

Сообщение zelenin » 2016.07.06, 17:00

а что, виновато расширение? или у вас действительно не включены расширения, указанные в логе?

Аватара пользователя
Sergalas
Сообщения: 594
Зарегистрирован: 2015.10.15, 12:39

Re: Yii2-user

Сообщение Sergalas » 2016.07.06, 23:06

zelenin писал(а):а что, виновато расширение? или у вас действительно не включены расширения, указанные в логе?
Это включены ?

Код: Выделить всё

grep -Hrv ";" /etc/php/5.6 | grep -i "extension="
/etc/php/5.6/mods-available/pdo.ini:extension=pdo.so
/etc/php/5.6/mods-available/xdebug.ini:zend_extension=xdebug.so
/etc/php/5.6/mods-available/posix.ini:extension=posix.so
/etc/php/5.6/mods-available/mysqli.ini:extension=mysqli.so
/etc/php/5.6/mods-available/json.ini:extension=json.so
/etc/php/5.6/mods-available/exif.ini:extension=exif.so
/etc/php/5.6/mods-available/sysvsem.ini:extension=sysvsem.so
/etc/php/5.6/mods-available/gettext.ini:extension=gettext.so
/etc/php/5.6/mods-available/pdo_mysql.ini:extension=pdo_mysql.so
/etc/php/5.6/mods-available/opcache.ini:zend_extension=opcache.so
/etc/php/5.6/mods-available/readline.ini:extension=readline.so
/etc/php/5.6/mods-available/mysqlnd.ini:extension=mysqlnd.so
/etc/php/5.6/mods-available/calendar.ini:extension=calendar.so
/etc/php/5.6/mods-available/mbstring.ini:extension=mbstring.so
/etc/php/5.6/mods-available/sysvshm.ini:extension=sysvshm.so
/etc/php/5.6/mods-available/ctype.ini:extension=ctype.so
/etc/php/5.6/mods-available/mysql.ini:extension=mysql.so
/etc/php/5.6/mods-available/sockets.ini:extension=sockets.so
/etc/php/5.6/mods-available/tokenizer.ini:extension=tokenizer.so
/etc/php/5.6/mods-available/ftp.ini:extension=ftp.so
/etc/php/5.6/mods-available/sysvmsg.ini:extension=sysvmsg.so
/etc/php/5.6/mods-available/fileinfo.ini:extension=fileinfo.so
/etc/php/5.6/mods-available/phar.ini:extension=phar.so
/etc/php/5.6/mods-available/iconv.ini:extension=iconv.so
/etc/php/5.6/mods-available/shmop.ini:extension=shmop.so
это правда php 5.6 я на него перешел думал запустится но там теже ошибки. Как посмотреть какие расширения php должны быть включены и где их проверить на включение?
Последний раз редактировалось Sergalas 2016.07.06, 23:08, всего редактировалось 1 раз.

zelenin
Сообщения: 10099
Зарегистрирован: 2013.04.20, 11:30

Re: Yii2-user

Сообщение zelenin » 2016.07.06, 23:08

сомневаюсь, тут же про 5.6.

Аватара пользователя
Sergalas
Сообщения: 594
Зарегистрирован: 2015.10.15, 12:39

Re: Yii2-user

Сообщение Sergalas » 2016.07.06, 23:09

zelenin писал(а):сомневаюсь, тут же про 5.6.
Там те же ошибки я просто перешел на php 56 и ответ поправил

Аватара пользователя
Sergalas
Сообщения: 594
Зарегистрирован: 2015.10.15, 12:39

Re: Yii2-user

Сообщение Sergalas » 2016.07.06, 23:15

zelenin писал(а):сомневаюсь, тут же про 5.6.
вот семерашные

Код: Выделить всё

grep -Hrv ";" /etc/php/5.6 | grep -i "extension="
/etc/php/7.0/mods-available/gd.ini:extension=gd.so
/etc/php/7.0/mods-available/xmlreader.ini:extension=xmlreader.so
/etc/php/7.0/mods-available/simplexml.ini:extension=simplexml.so
/etc/php/7.0/mods-available/pdo.ini:extension=pdo.so
/etc/php/7.0/mods-available/xdebug.ini:zend_extension=xdebug.so
/etc/php/7.0/mods-available/posix.ini:extension=posix.so
/etc/php/7.0/mods-available/mysqli.ini:extension=mysqli.so
/etc/php/7.0/mods-available/json.ini:extension=json.so
/etc/php/7.0/mods-available/exif.ini:extension=exif.so
/etc/php/7.0/mods-available/sysvsem.ini:extension=sysvsem.so
/etc/php/7.0/mods-available/gettext.ini:extension=gettext.so
/etc/php/7.0/mods-available/pdo_mysql.ini:extension=pdo_mysql.so
/etc/php/7.0/mods-available/opcache.ini:zend_extension=opcache.so
/etc/php/7.0/mods-available/readline.ini:extension=readline.so
/etc/php/7.0/mods-available/mysqlnd.ini:extension=mysqlnd.so
/etc/php/7.0/mods-available/calendar.ini:extension=calendar.so
/etc/php/7.0/mods-available/mbstring.ini:extension=mbstring.so
/etc/php/7.0/mods-available/sysvshm.ini:extension=sysvshm.so
/etc/php/7.0/mods-available/dom.ini:extension=dom.so
/etc/php/7.0/mods-available/ctype.ini:extension=ctype.so
/etc/php/7.0/mods-available/sockets.ini:extension=sockets.so
/etc/php/7.0/mods-available/mcrypt.ini:extension=mcrypt.so
/etc/php/7.0/mods-available/tokenizer.ini:extension=tokenizer.so
/etc/php/7.0/mods-available/ftp.ini:extension=ftp.so
/etc/php/7.0/mods-available/wddx.ini:extension=wddx.so
/etc/php/7.0/mods-available/sysvmsg.ini:extension=sysvmsg.so
/etc/php/7.0/mods-available/fileinfo.ini:extension=fileinfo.so
/etc/php/7.0/mods-available/phar.ini:extension=phar.so
/etc/php/7.0/mods-available/xmlwriter.ini:extension=xmlwriter.so
/etc/php/7.0/mods-available/iconv.ini:extension=iconv.so
/etc/php/7.0/mods-available/xml.ini:extension=xml.so
/etc/php/7.0/mods-available/xsl.ini:extension=xsl.so
/etc/php/7.0/mods-available/shmop.ini:extension=shmop.so

Onotole
Сообщения: 1808
Зарегистрирован: 2012.12.24, 12:49

Re: Yii2-user

Сообщение Onotole » 2016.07.06, 23:18

cli тоже этими конфигами пользуется?

zelenin
Сообщения: 10099
Зарегистрирован: 2013.04.20, 11:30

Re: Yii2-user

Сообщение zelenin » 2016.07.06, 23:26

mods-available - доступные моды
mods-enabled - включенные моды

симлинки прокиньте. или заюзайте phpenmod или как-то так.

Аватара пользователя
webplus
Сообщения: 144
Зарегистрирован: 2012.02.24, 22:05
Контактная информация:

Re: Yii2-user

Сообщение webplus » 2016.08.02, 13:52

При регистрации юзера не создает ему роль, а просто добавляет в таблицу данные, а в таблицу auth_assignment не вносит связь с ролью.
У меня на сайте есть роль admin - это для админки юзеров для бекенда, и на фронтенде роль author и мне надо чтоб это роль была при регистрации. Подскажите как эту роль реализовать

Аватара пользователя
vitaxa_prog
Сообщения: 297
Зарегистрирован: 2011.06.06, 22:44
Откуда: Волноваха

Re: Yii2-user

Сообщение vitaxa_prog » 2016.08.02, 15:47

webplus писал(а):Подскажите как эту роль реализовать
1. Переопределить контроллер UserController.
2. В методе register добавить присвоение роли. После того как пользователь создан.
Например так:

Код: Выделить всё

Yii::$app->authManager->assign('ваша_роль', $user_id);
 
Можете присваивание роли, вынести в модель.
А можете даже написать поведение.
В принципе ничего нет невозможного.
— Вы думаете?
— Для человека. С интеллектом.

Аватара пользователя
ElisDN
Сообщения: 4590
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Yii2-user

Сообщение ElisDN » 2016.08.02, 15:58

webplus писал(а):Подскажите как эту роль реализовать
viewtopic.php?f=19&t=37685&p=193702#p193702
Не забудьте пройти мастер-класс по Yii2.

louisvuitton
Сообщения: 135
Зарегистрирован: 2014.02.16, 03:09

Re: Yii2-user

Сообщение louisvuitton » 2016.11.15, 10:24

Провел я composer update, поправил некоторые нестыковки, но тем не менее получаю предупреждения Notice

У всех так? что делать? (

Изображение

Loveorigami
Сообщения: 698
Зарегистрирован: 2014.08.27, 21:54

Re: Yii2-user

Сообщение Loveorigami » 2016.11.15, 21:16

Отключите использование флешей модуля.
В конфиге поставьте в enableFlashMessages = false

Ответить